Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [solved]virtualbox after update (qt5) doesnt work (Read 169 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[solved]virtualbox after update (qt5) doesnt work

hi, after the last update i cant launch virtualbox.
upgraded libelogind (239.2-1 -> 239.3-1)
warning: /etc/elogind/logind.conf installed as /etc/elogind/logind.conf.pacne
upgraded elogind (239.2-1 -> 239.3-1)
upgraded garcon (0.6.1-2 -> 0.6.2-1)
upgraded git (2.19.2-1 -> 2.20.0-1)
upgraded glslang (7.9.2888-2 -> 7.10.2984-1)
upgraded shaderc (2018.0-2 -> 2018.0-3)
upgraded libplacebo (0.6.0-1 -> 0.6.0-2)
upgraded linux (4.19.6.artix1-1 -> 4.19.8.arch1-1)
upgraded qt5-base (5.11.2-3 -> 5.12.0-1)
upgraded qt5-declarative (5.11.2-1 -> 5.12.0-1)
upgraded qt5-location (5.11.2-2 -> 5.12.0-1)
upgraded qt5-multimedia (5.11.2-1 -> 5.12.0-1)
upgraded qt5-script (5.11.2-1 -> 5.12.0-1)
upgraded qt5-sensors (5.11.2-1 -> 5.12.0-1)
upgraded qt5-speech (5.11.2-1 -> 5.12.0-1)
upgraded qt5-svg (5.11.2-1 -> 5.12.0-1)
upgraded qt5-tools (5.11.2-2 -> 5.12.0-1)
upgraded qt5-webchannel (5.11.2-1 -> 5.12.0-1)
upgraded qt5-webkit (5.212.0alpha2-21 -> 5.212.0alpha2-22)
upgraded qt5-x11extras (5.11.2-1 -> 5.12.0-1)
upgraded qt5-xmlpatterns (5.11.2-1 -> 5.12.0-1)
upgraded vim-runtime (8.1.0542-1 -> 8.1.0570-1)
upgraded vim (8.1.0542-1 -> 8.1.0570-1)
upgraded virtualbox-guest-modules-artix (5.2.22-6 -> 5.2.22-10)
upgraded virtualbox-host-modules-artix (5.2.22-6 -> 5.2.22-10)
upgraded wireshark-cli (2.6.4-2 -> 2.6.5-1)
reboot, try to launch from console & said :
WARNING: The vboxdrv kernel module is not loaded. Either there is no module
         available for the current kernel (4.19.8-artix1-1-ARTIX) or it failed to
         load. Please recompile the kernel module and install it by

           sudo /sbin/vboxconfig

         You will not be able to start VMs until this problem is fixed.

libEGL warning: DRI2: failed to authenticate
segment fault
[]>modprobe vboxdrv
libEGL warning: DRI2: failed to authenticate
segment fault
if try with []>okular
then say libEGL warning: DRI2: failed to authenticate
but works.
i got installed extra/mesa 18.2.6-1
so i dowgraded host n guest artix modules with same results

Re: virtualbox after update doesnt owrk

Reply #1
Could this be as silly as a mistake in package naming?
The module looks for linux-4.19-artix1 and the new name is linux-4.19-arch1, even though it installs as artix1-artix?
Because those same modules worked with 4.19-6 it makes no sense to not be working with 4.19-8, unless something went haywire whole building the kernel.
Code: [Select]
Kernel: 4.19.8-artix1-1-ARTIX 
local/linux 4.19.8.arch1-1 (base)
local/linux-headers 4.19.8.arch1-1
anti-X  - artix - obarun - Void - systemD Free Space

I can no longer participate in a public forum side by side with neo-nazis and NSA trolls in a moderated sterile environment that is good for business.
Obviously the terms Open and Free mean nothing to you, or your business!

Re: virtualbox after update doesnt owrk

Reply #2
I found that another application that depends on qt5 does not work either, so i downgrade qt5-base & qt5-x11Extra, and virtualbox is working again but not the others applications. maybe a bug from qt5, for the moment I'm going to downgrade everything qt5.

edit: VBox is not working, just open de main console but cant boot any VM. i dowgrade all qt5, and another app start working,  when try to start a VM ,says
Failed to open/create the internal network 'HostInterfaceNetworking-enp3s0' (VERR_SUPDRV_COMPONENT_NOT_FOUND).
Failed to attach the network LUN (VERR_SUPDRV_COMPONENT_NOT_FOUND).
One of the kernel modules was not successfully loaded. Make sure that no kernel modules from an older version of VirtualBox exist. Then try to recompile and reload the kernel modules by executing '/sbin/vboxconfig' as root (VERR_SUPDRV_COMPONENT_NOT_FOUND).

Re: virtualbox after update (qt5) doesnt work

Reply #3
After today's update everything returned to normal. something from the qt libraries towards noise surely