Skip to main content
Topic: double-conversion version is too new (Read 201 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

double-conversion version is too new

The arch extra repository currently has double-conversion 3.1.1-1, while the artix world repository has double-conversion 3.1.2-1. Packages such as sddm are not built against double-conversion 3.1.2-1, and thus fail to start with a "error while loading shared libraries" error. A temporary fix for those affected is to install the double-conversion package from extra.

Re: double-conversion version is too new

Reply #1
Just came across this. Did a full upgrade and all QT programs I tried failed to start because of it.
Downgrading double-conversion to  3.1.1-1 fixed it.

How has this happened ? There isn't a  double-conversion-3.1.2-1 even in Arch testing from what I can tell from a quick look.

Edit:
https://archive.archlinux.org/packages/d/double-conversion/
shows double-conversion-3.1.2-1 added on the 4th so I guess they reverted it or something. Oh well. I won't waste anymore time looking as to why. :)

Re: double-conversion version is too new

Reply #2
Hi, same for me. After latest upgrade which included the update to double-conversion 3.1.2-1, ssdm fails to start:
Code: [Select]
/usr/bin/sddm: error while loading shared libraries: libdouble-conversion.so.3.0.0: cannot open shared object file: No such file or directory

I fixed this for me by creating an additional symlink:
Code: [Select]
lrwxrwxrwx 1 root root    25  7. Mär 20:19 /usr/lib/libdouble-conversion.so -> libdouble-conversion.so.3
lrwxrwxrwx 1 root root    29  7. Mär 20:19 /usr/lib/libdouble-conversion.so.3 -> libdouble-conversion.so.3.1.2
lrwxrwxrwx 1 root root    34  8. Mär 07:46 /usr/lib/libdouble-conversion.so.3.0.0 -> /usr/lib/libdouble-conversion.so.3
-rwxr-xr-x 1 root root 87752  7. Mär 20:19 /usr/lib/libdouble-conversion.so.3.1.2

May need to clean this later, when the package is fixed. :)

Re: double-conversion version is too new

Reply #3
double-conversion broke qt5-base, what is now fixed in  qt5-base-5.12.1-2.1-x86_64. after update should all again work.

seems as error of archlinux, they put before 38 hour 3.1.2 to extra, but still not exist... hmm


Re: double-conversion version is too new

Reply #5
Guessing here but this is what I think happened:

Arch updated to double-conversion 3.1.2-1  and then quickly pulled it. The newer package is in archive.archlinux.org but not in their actual repo.. But they leave the newer PKGBUILD (3.1.2-1)  in place which the Artix build system spots as newer and builds and adds to the Artix repo's.

Wrong or right ? :)

Re: double-conversion version is too new

Reply #6
now is in staging double-conversion 3.1.3