Skip to main content
Topic: libice and graphics issue XFCE (Read 594 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

libice and graphics issue XFCE

I had not updated since 2019-07-15 so many packages were upgraded today. The boot went to a black screen but later the desktop appeared after a longer than usual delay. The bottom of the XFCE terminal is a broken white line, and the window icons to maximise and minimise are wrong, if you hover on them they change. Trying the fallback initramfs made no difference. There were no errors in syslog but Xorg.0.log had an error I had not seen before:

Code: [Select]
[    11.545] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[    11.546] (II) xfree86: Adding drm device (/dev/dri/card0)
[    11.546] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 10 paused 1
[    11.546] (EE) Error systemd-logind returned paused fd for drm node
[    11.546] (II) systemd-logind: releasing fd for 226:0

Downgrading the kernel did not fix it.

Re: Graphics issue nouveau XFCE

Reply #1
It could be an update to your graphics driver, mesa or Xorg. Try downgrading each one in turn until you find the culprit.


Re: Graphics issue nouveau XFCE

Reply #2
The delay getting to the desktop - move the mouse or hit a key to make it appear - is libice
libice-1.0.10-1-x86_64.pkg.tar.xz  libice-1.0.9-2-x86_64.pkg.tar.xz

The black and white broken bottom border on the un-maximized terminal window changes to a patterned multi-color border on the bottom and right side when glu is downgraded
glu-9.0.0-5-x86_64.pkg.tar.xz  glu-9.0.1-1-x86_64.pkg.tar.xz

Downgrading pango gets rid of the broken border without glu being downgraded
pango-1:1.43.0-2-x86_64.pkg.tar.xz  pango-1:1.44.4-1-x86_64.pkg.tar.xz

Haven't found the cause of the messed up maximize and minimize buttons yet.

Re: Graphics issue nouveau XFCE

Reply #3
Perhaps not pango after all, and the border pattern was different on one boot without any change to glu.  Now I have these packages still upgraded / installed from the update, without libice there is no delay getting to the desktop, but I still have the funny bottom border on un-maximized windows and the faulty max/min buttons. Downgrading xfce4-terminal means it doesn't work, xfwm4 stops it booting as it won't log in on any tty. Perhaps a general 'XFCE' problem?
Code: [Select]
 upgraded libtasn1 (4.13-1 -> 4.14-1)          --but no old one in cache?
 installed dav1d (0.4.0-1)
 upgraded libxfce4util (4.13.4-1 -> 4.14.0-1)
 upgraded xfconf (4.12.1-7 -> 4.14.1-1)
 upgraded libxfce4ui (4.13.6-1 -> 4.14.1-2)
 installed python-attrs (19.1.0-1)
 upgraded xfce4-appfinder (4.12.0-5 -> 4.14.0-1)
 upgraded xfce4-panel (4.12.2-1 -> 4.14.0-1)
 upgraded xfce4-session (4.12.1-11 -> 4.14.0-2)
 upgraded xfce4-settings (4.12.4-2 -> 4.14.0-1)
 upgraded xfce4-terminal (0.8.8-1 -> 0.8.8-2)
 upgraded xfdesktop (4.13.5-1 -> 4.14.1-2)
 installed libxpresent (1.0.0-1)
 upgraded xfwm4 (4.12.5-1 -> 4.14.0-1)

Re: Graphics issue nouveau XFCE

Reply #4
Problems with XFCE4 are being discussed on the Arch forum
I have 'ignored' libice to get rid of the black screen at boot, and upgraded everything else. This means the title bar and surround of windows looks odd, but it's perfectly usable if not as pretty as usual. That's probably related to the window manager but downgrading that means downgrading a stack of other XFCE stuff too or it breaks the OS. And I wanted to be updated as far as possible to install some new packages which was what I was originally intending to do yesterday...  ;D

Re: Graphics issue nouveau XFCE

Reply #5
Another observation - it is only the topmost window that has mouse focus which looks strange. Windows change to looking normal if another one is clicked in.

Re: Graphics issue nouveau XFCE

Reply #6
Looking for more info I found these threads:
XFCE forum (1) XFCE forum (2)

So I ran:

Code: [Select]
$ xfwm4 --vblank=xpresent --replace
$ xfwm4 --vblank=off --replace
$ xfwm4 --vblank=glx --replace &

It worked! After EVERY command ?  (That's all the options - it works on all of them.) Now, another unexpected thing, I did not run any command to make any setting permanent, and the last command for glx left it on the default that should have been there originally, but having rebooted it STILL works  :o  (libice is still downgraded atm btw.)

Re: Graphics issue nouveau XFCE

Reply #7
I have not had the "working after reboot" happen again although it still works after any of glx, off or xpresent. So it could be a boot race condition where the HW is not detected properly when xfwm starts? Just restarting the window manager using no options with the system up and running fixes the problems with the in focus window not displaying properly :
Code: [Select]
$ xfwm4 --replace &

Re: Graphics issue nouveau XFCE

Reply #8
Un - ignoring libice sees the black screen after boot reappear and the in focus window issue remains unchanged, so no resolution from updates as yet.
I found this bug report on the libice gitlab bug tracker.
It suggested adding this to the start of xinitrc, if using startx:
export ICEAUTHORITY=/home/$USER/.ICEauthority
But that didn't help in my case. So more investigation is required.

Re: Graphics issue nouveau XFCE

Reply #9
There is something wrong with the Artix libice binary package, perhaps a build environment issue, there might be some missing makedeps? However, libbsd is only installed because of mencoder I think, and librt and libpthread are both owned by glibc 2.29-4. If I build it from source, either using the Artix pkgbuild, or from git, still at the last release, it works fine. ldd -v gives different results on the .so, there is more output on my package:
Code: [Select]
My pkg built from the Artix PKGBUILD:
ldd -v /usr/lib/ (0x00007ffc167be000) => /usr/lib/ (0x00007ff3e8d54000) => /usr/lib/ (0x00007ff3e8b91000) => /usr/lib/ (0x00007ff3e8b86000)
/usr/lib64/ (0x00007ff3e8faa000) => /usr/lib/ (0x00007ff3e8b65000)

Version information:
/usr/lib/ (LIBBSD_0.2) => /usr/lib/ (GLIBC_2.3) => /usr/lib/ (GLIBC_2.11) => /usr/lib/ (GLIBC_2.14) => /usr/lib/ (GLIBC_2.8) => /usr/lib/ (GLIBC_2.4) => /usr/lib/ (GLIBC_2.3.4) => /usr/lib/ (GLIBC_2.2.5) => /usr/lib/
/usr/lib/ (GLIBC_2.2.5) => /usr/lib/ (GLIBC_2.25) => /usr/lib/ (GLIBC_2.16) => /usr/lib/ (GLIBC_2.14) => /usr/lib/ (GLIBC_2.8) => /usr/lib/ (GLIBC_2.3.2) => /usr/lib/ (GLIBC_2.4) => /usr/lib/ (GLIBC_2.3.4) => /usr/lib/ (GLIBC_2.2.5) => /usr/lib/ (GLIBC_2.3) => /usr/lib/
/usr/lib/ (GLIBC_2.3) => /usr/lib64/ (GLIBC_PRIVATE) => /usr/lib64/
/usr/lib/ (GLIBC_2.3.2) => /usr/lib/ (GLIBC_PRIVATE) => /usr/lib/ (GLIBC_2.2.5) => /usr/lib/ (GLIBC_2.14) => /usr/lib/ (GLIBC_2.3.2) => /usr/lib/ (GLIBC_2.4) => /usr/lib/ (GLIBC_2.2.5) => /usr/lib/ (GLIBC_PRIVATE) => /usr/lib/
/usr/lib/ (GLIBC_2.2.5) => /usr/lib64/ (GLIBC_PRIVATE) => /usr/lib64/ (GLIBC_2.7) => /usr/lib/ (GLIBC_2.14) => /usr/lib/ (GLIBC_2.3.2) => /usr/lib/ (GLIBC_2.4) => /usr/lib/ (GLIBC_2.2.5) => /usr/lib/ (GLIBC_PRIVATE) => /usr/lib/

The binary pkg from Artix world repo:
ldd -v /usr/lib/ (0x00007ffc6e1e6000) => /usr/lib/ (0x00007fcdb1403000)
/usr/lib64/ (0x00007fcdb1604000)

Version information:
/usr/lib/ (GLIBC_2.3) => /usr/lib/ (GLIBC_2.11) => /usr/lib/ (GLIBC_2.14) => /usr/lib/ (GLIBC_2.8) => /usr/lib/ (GLIBC_2.4) => /usr/lib/ (GLIBC_2.25) => /usr/lib/ (GLIBC_2.3.4) => /usr/lib/ (GLIBC_2.2.5) => /usr/lib/
/usr/lib/ (GLIBC_2.3) => /usr/lib64/ (GLIBC_PRIVATE) => /usr/lib64/