Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [Solved] ananicy breaks s6 (Read 501 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[Solved] ananicy breaks s6

After installing ananicy and putting “exec ananicy start” in the rc.local file, my system becomes borked. I can’t launch sway or even use the poweroff command to shut off the computer. I had to uninstall ananicy and remove it from the rc.local file for s6 to work again. ananicy does include cgroups rules. Could this be breaking s6?

Re: ananicy breaks s6

Reply #1
We start s6 service really not from /etc/rc.local.
Please learn how to start service on s6 8)  ;)

Re: ananicy breaks s6

Reply #2
Please be careful with the rc.local file. You can very easily break things if you put bad commands in there. :P I took a quick look at this program on github and it explicitly depends on systemd. It runs "systemd-notify" multiple times, so you're unfortunately out of luck here.

Re: ananicy breaks s6

Reply #3
My machine is ok now, but that explains everything. Thanks for the info. I’ll make an issue on his GitHub page ( and see if he can make the program more modular, and support other init systems. I’ll upload an ananicy-s6 package if that time comes.

Re: [Solved] ananicy breaks s6

Reply #4
Hi @shoober420 again.

Wishing that you will have fun with ananicy packages on universe repo.