Skip to main content
Topic: The name org.freedesktop.timedate1 was not provided by any .service files (Read 1331 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

The name org.freedesktop.timedate1 was not provided by any .service files

hi,

i freshly installed my first artix system. after the first start i wanted to change time settings in the gui and got the error

The name org.freedesktop.timedate1 was not provided by any .service files

Re: The name org.freedesktop.timedate1 was not provided by any .service files

Reply #1
I am having the same problem.  Interestingly, /etc/localtime is correctly symlinked to the appropriate file in /usr/share/zoneinfo, but the GUI for time and date says no timezone is configured, and trying to set it results in the above error.
... because systemd sucks

Re: The name org.freedesktop.timedate1 was not provided by any .service files

Reply #2
Use "timeset-gui" in the AUR it is designed to work on openrc.

Re: The name org.freedesktop.timedate1 was not provided by any .service files

Reply #3
openrc-settingsd can be installed, it provides dbus interfaces to systemd's localectrl, timedatectl, and hostnamectl.
So clock and timezone settings work in DEs.

Re: The name org.freedesktop.timedate1 was not provided by any .service files

Reply #4
hi,

i freshly installed my first artix system. after the first start i wanted to change time settings in the gui and got the error

The name org.freedesktop.timedate1 was not provided by any .service files

why would that be a service? sigh..

Re: The name org.freedesktop.timedate1 was not provided by any .service files

Reply #5
why would that be a service? sigh..

Service is optional, it has dbus activation.
The package provide dbus interfaces as previously already stated.
Arch DEs expect these dbus interfaces, ie systemd, or else the DEs gui throws an error.

Re: The name org.freedesktop.timedate1 was not provided by any .service files

Reply #6
Sorry to bump an old thread, but is there a runit solution for this issue? I was going to try timeset-gui but it kept asking for more and more dependencies so I pulled out.

I can set the date/time in the terminal but it doesn't stay correct.

Thanks

Re: The name org.freedesktop.timedate1 was not provided by any .service files

Reply #7
Sorry to bump an old thread, but is there a runit solution for this issue? I was going to try timeset-gui but it kept asking for more and more dependencies so I pulled out.

I can set the date/time in the terminal but it doesn't stay correct.

Thanks
Unfortunately, no. openrc-settingsd are locked down to OpenRC, and it seems there are no more alternatives (systembsd seems to be BSD-only). So setting time using GUI is unsupported for now.
You can use NTP services (such as OpenNTPD) to automatically set your time.
the runit guy on artix

Re: The name org.freedesktop.timedate1 was not provided by any .service files

Reply #8
Unfortunately, no. openrc-settingsd are locked down to OpenRC, and it seems there are no more alternatives (systembsd seems to be BSD-only). So setting time using GUI is unsupported for now.
You can use NTP services (such as OpenNTPD) to automatically set your time.

Thanks for the information konimex

Re: The name org.freedesktop.timedate1 was not provided by any .service files

Reply #9
Service is optional, it has dbus activation.
The package provide dbus interfaces as previously already stated.
Arch DEs expect these dbus interfaces, ie systemd, or else the DEs gui throws an error.


I got it... that was a critism of the state of linux wrapped in a retorical question :(