Skip to main content
Topic: Inconsistent dependencies in world/x264 and world/ffmpeg, breaking installation. (Read 385 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Inconsistent dependencies in world/x264 and world/ffmpeg, breaking installation.

world/x264 depends on:

Code: [Select]
[...]
libavcodec.so=57-64
libavformat.so=57-64
libavutil.so=55-64
[...]
libswscale.so=4-64

world/ffmpeg provides:

Code: [Select]
libavcodec.so=58-64
[...]
libavformat.so=58-64
[...]
libavutil.so=56-64
[...]
libswscale.so=5-64

So, Artix' x264 cannot be installed using Artix' ffmpeg.

Re: Inconsistent dependencies in world/x264 and world/ffmpeg, breaking installation.

Reply #1
till you get a more experienced response what happens if you try

Code: [Select]
pacman -S ffmpeg x264 

I was going to suggest you use --force but on my installation, I had ffmpeg, and x264 installed just fine side by side.  I don't see any conflicts.

Re: Inconsistent dependencies in world/x264 and world/ffmpeg, breaking installation.

Reply #2
till you get a more experienced response what happens if you try

Code: [Select]
pacman -S ffmpeg x264 

Here you are:

pacman -Syy and then pacman -S world/x264 world/ffmpeg:

Code: [Select]
warning: x264-2:152.20171224-2 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: x264: requires libavcodec.so=57-64
:: x264: requires libavformat.so=57-64
:: x264: requires libavutil.so=55-64
:: x264: requires libswscale.so=4-64
:: libquicktime: installing ffmpeg (1:4.0-2) breaks dependency 'libavcodec.so=57-64'
:: libquicktime: installing ffmpeg (1:4.0-2) breaks dependency 'libswscale.so=4-64'

pacman -Su world/x264 world/ffmpeg:

Code: [Select]
warning: x264-2:152.20171224-2 is up to date -- reinstalling
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: x264: requires libavcodec.so=57-64
:: x264: requires libavformat.so=57-64
:: x264: requires libavutil.so=55-64
:: x264: requires libswscale.so=4-64


And the one you requested, pacman -Su world/ffmpeg:

Code: [Select]
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: x264: installing ffmpeg (1:4.0-2) breaks dependency 'libavcodec.so=57-64'
:: x264: installing ffmpeg (1:4.0-2) breaks dependency 'libavformat.so=57-64'
:: x264: installing ffmpeg (1:4.0-2) breaks dependency 'libavutil.so=55-64'
:: x264: installing ffmpeg (1:4.0-2) breaks dependency 'libswscale.so=4-64'

My Artix mirror list is:

Code: [Select]
Server = http://mirror.clarkson.edu/artix-linux/repos/$repo/os/$arch
Server = http://ftp.sh.cvut.cz/artix-linux/$repo/os/$arch
Server = http://ftp.cc.uoc.gr/mirrors/linux/artixlinux/$repo/os/$arch

Using
Code: [Select]
Server = http://mirror1.artixlinux.org/repos/$repo/os/$arch
as single mirror (of course I did pacman -Syy after changing the mirror list) does not change things.

Quote
I was going to suggest you use --force but on my installation, I had ffmpeg, and x264 installed just fine side by side.  I don't see any conflicts.

Having to use --force is no acceptable solution.

 

Re: Inconsistent dependencies in world/x264 and world/ffmpeg, breaking installation.

Reply #3
Hmm you're right. There is indeed a conflict between x264 and ffmpeg. Interestingly enough, the PKGBUILDs in Arch and Artix look the same to me. Note that you can install x264 from Arch's extra repo (pacman -S extra/x264) just fine. I'm going to guess that x264 in world must have accidentally been built with the old ffmpeg thus causing the dependency issue.

Re: Inconsistent dependencies in world/x264 and world/ffmpeg, breaking installation.

Reply #4
Hmm you're right. There is indeed a conflict between x264 and ffmpeg. Interestingly enough, the PKGBUILDs in Arch and Artix look the same to me. Note that you can install x264 from Arch's extra repo (pacman -S extra/x264) just fine. I'm going to guess that x264 in world must have accidentally been built with the old ffmpeg thus causing the dependency issue.

Dependencies of Arch's x264 and Artix' x264 differ.

Dependencies of extra/x264:
Code: [Select]
glibc  libavcodec.so=58-64  libavformat.so=58-64  libavutil.so=56-64  liblsmash.so=2-64  libswscale.so=5-64

Dependencies of world/x264:
Code: [Select]
glibc  libavcodec.so=57-64  libavformat.so=57-64  libavutil.so=55-64  liblsmash.so=2-64  libswscale.so=4-64

Package version in both is 2:152.20171224-2.

Seems that while building x264 for Artix, an old ffmpeg was used.

I can install up to date extra/x264 without any dependency-problems with up to date world/ffmpeg.


Re: Inconsistent dependencies in world/x264 and world/ffmpeg, breaking installation.

Reply #6
Seems that the problem has been silently fixed now (world/x264 has been updated, $pkgrel is 2.1).