Skip to main content
Topic: How do I go about installing tkpacman or pamac? (Read 1360 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

How do I go about installing tkpacman or pamac?

When I looked up how to install either of these 2,
yaourt -S tkpacman Or packer -S tkpacman

packer -S pamac-aur

I wasn't able to because neither yaourt and packer exist on my computer. Is it possible to install tkpacman or pamac with just packman commands?

Re: How do I go about installing tkpacman or pamac?

Reply #1
yeah it is possible to install pamac.
artix runit xfce4
I am vegeterian ^.^

May all beings have happiness and the causes of happiness;
May all beings be free from suffering and the causes of suffering;

Re: How do I go about installing tkpacman or pamac?

Reply #2
Yes, you just need to make sure you have base-devel installed, check out the package's repo witih git, and then run makepkg -si to build and install the package. See the Arch Wiki page for some more details.

Re: How do I go about installing tkpacman or pamac?

Reply #3
Which desktop environment are you using? If you are using lxqt or plasma, I would recommend octopi instead of pamac.

Best regards.
We should try to be kind to everyone.....we are all fighting some sort of battle.

Re: How do I go about installing tkpacman or pamac?

Reply #4
you can install trizen with sudo pacman -Syyu then sudo pacman -S  base-devel  trizen then inst you are good to go.
 to check package availability with  trizen  pacman           will list all pkg to do with pacman enter the pkg no your good to go.
all other command are per pacman.

Re: How do I go about installing tkpacman or pamac?

Reply #5
Both exist in 2 variations on main repositories, if you still want the aur-versions you can install them using there:

I have been using yaourtix since it first came out and haven't had a problem.
If you have gremlins enabled try:
# pacman -S yaourtix-git

Code: [Select]
 galaxy-gremlins/yaourtix-git 1.9.r3.gfe1bcdd-6
    Yaourt (= a pacman wrapper with extended features and AUR support) patched with user definable repo-support
    for building from source, and other customizepkg-enhancements. Artix support included.
 galaxy/yaourt 1.9-2
    A pacman wrapper with extended features and AUR support
 galaxy/pamac 7.3.4-1
    A Gtk3 frontend for libalpm
 galaxy/pamac-classic 6.7.0-1
    A Gtk3 frontend for libalpm

There is an interesting discussion going on in reddit r/archlinux about AUR wrappers for those deeply into it.
anti-X  - artix - obarun - Void - systemD Free Space

I can no longer participate in a public forum side by side with neo-nazis and NSA trolls in a moderated sterile environment that is good for business.
Obviously the terms Open and Free mean nothing to you, or your business!

Re: How do I go about installing tkpacman or pamac?

Reply #6
Just  remember   yaourt is depreciated not maintained,  The same goes for pacaur, yay is also a better choice as it does not use tmps to build packages by default and ticks all the boxes on the Arch wiki.

 

Re: How do I go about installing tkpacman or pamac?

Reply #7
I am wondering which packages do I require to make it as user friendly as possible?

Re: How do I go about installing tkpacman or pamac?

Reply #8
everything_is_wrong_with_aur_helpers

yaourtix is developed by an artix community member and has been updated quite a few times in the past few months
anti-X  - artix - obarun - Void - systemD Free Space

I can no longer participate in a public forum side by side with neo-nazis and NSA trolls in a moderated sterile environment that is good for business.
Obviously the terms Open and Free mean nothing to you, or your business!

Re: How do I go about installing tkpacman or pamac?

Reply #9
everything_is_wrong_with_aur_helpers

yayaourtiourtix is developed by an artix community member and has been updated quite a few times in the past few months
I did not mention yaourtix as I know that.

That reddit  article is totally wrong reddit is a FUD site.  No helper asks for a password for any AUR build. it does ask for a password to install deps from the repro then drops the privileges to make the package then asks for the password to in install.
That is at least if you are not a Manjaro user then you just install blind with ---no-confirm. After which you blame Arch Linux when your system will not boot.
Also the latest from Manjaro users advising to update from TTY as Manjaro now breaks on every update apparently. Not done that for years since the Sidux days. Then Manjaro claim to be newbie freindly give me Arch/Artix any day.

Re: How do I go about installing tkpacman or pamac?

Reply #10
I am wondering since Artix was related to Manjaro, which packages do I require to make it as user friendly and close to manjaro as possible?

It is related only in that both are Arch derivatives. You can customise your installation any way you want. You will have to be more specific when you say that you want it to make it more similar to Manjaro.

Re: How do I go about installing tkpacman or pamac?

Reply #11
As @physkets‍ stated you can configure your system as you wish to make it look more like Manjaro. However, Artix by its very nature is not going to be as "user friendly" as Manjaro attempts to be with their specific tools. 
That in no way implies that those of us here at Artix are not friendly to users however. ;)

Best regards.
We should try to be kind to everyone.....we are all fighting some sort of battle.

Re: How do I go about installing tkpacman or pamac?

Reply #12
Speaking of yaourt and yaourtix, AUR management removed both yaourt and yaourtix from the repository.
Whatever is wrong with yaourt is also wrong with many other AUR pac-wrappers as I have read, they are all insecure in their own unique ways.

Longlive yaourtix  :)
anti-X  - artix - obarun - Void - systemD Free Space

I can no longer participate in a public forum side by side with neo-nazis and NSA trolls in a moderated sterile environment that is good for business.
Obviously the terms Open and Free mean nothing to you, or your business!

Re: How do I go about installing tkpacman or pamac?

Reply #13
I find it hard to believe that some random dude has registered an AUR account on just to request a deletion of yaourtix.
Code: [Select]
rdeckard [1] filed a deletion request for yaourtix-git [2]:

This package is based on yaourt, which is no longer maintained
(https://github.com/archlinuxfr/yaourt/issues/382#issuecomment-475039781).

[1] https://aur.archlinux.org/account/rdeckard/
[2] https://aur.archlinux.org/pkgbase/yaourtix-git/

The request reason is also invalid, yaourtix is actively maintained.

Re: How do I go about installing tkpacman or pamac?

Reply #14
And AUR is full of outdated packages, and I am pretty sure I saw yaourt itself in AUR about a week ago.

If someone wants it they now have to come to artix to get it.
anti-X  - artix - obarun - Void - systemD Free Space

I can no longer participate in a public forum side by side with neo-nazis and NSA trolls in a moderated sterile environment that is good for business.
Obviously the terms Open and Free mean nothing to you, or your business!