Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] Issues with software on KDE Plasma in xorg that don't appear in wayland (Read 1732 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] Issues with software on KDE Plasma in xorg that don't appear in wayland

There are multiple applications that don't run correctly on xorg. One example is plasma browser integration, which doesn't show media controls on the desktop when playing videos. Another example is Discord, which doesn't display notifications or the system tray icon. One more example is Chromium, which can't connect to kwallet or inhibit the screensaver. These issues don't appear when I run Plasma under wayland. From research, it may be a dbus issue, but I'm not completely sure.


Re: Issues with software on KDE Plasma with xorg that don't appear with wayland

Reply #2
I did get the discord tray icon working by running DBUS_SESSION_BUS_ADDRESS=$(dbus-launch) in a terminal and then starting discord from the same terminal, but it displayed with a question mark. Notifications would also freeze the application. I have a feeling it has to do with DBUS_SESSION_BUS_ADDRESS, because it's not set at all. Let me also clarify that I'm using runit.

Re: Issues with software on KDE Plasma with xorg that don't appear with wayland

Reply #3
Assuming you run openrc, plesase post the output of

Code: [Select]
rc-status --all

Sounds like you don't have elogind running.

Plasma integration works fine.

Re: Issues with software on KDE Plasma with xorg that don't appear with wayland

Reply #4
As I stated in my previous comment, I'm using runit, not openrc. According to sv status elogind, it's running. If you're using openrc with plasma and xorg, and plasma integration is working, then this might be a runit issue.

Re: Issues with software on KDE Plasma with xorg that don't appear with wayland

Reply #5
When running discord from a terminal, I receive the following output:

Quote
(discord:8668): libappindicator-WARNING **: 16:48:50.856: Unable to get the session bus: Unknown or unsupported transport “disabled” for address “disabled:”

(discord:8668): LIBDBUSMENU-GLIB-WARNING **: 16:48:50.856: Unable to get session bus: Unknown or unsupported transport “disabled” for address “disabled:”

From research, all problems pertaining to a missing tray icon in apps like discord were solved by installing libappindicator-gtk3. However, I already have this package installed.

Re: Issues with software on KDE Plasma with xorg that don't appear with wayland

Reply #6
I've faced the same issue myself, at least in terms of Discord's tray icon not showing up. Void Linux seems to have run into this issue as well, which can be seen here. Not sure what the cause might be though.

Re: Issues with software on KDE Plasma with xorg that don't appear with wayland

Reply #7
It looks like a solution has been found here. Editing Plasma's desktop file to include "dbus-run-session" to the "Exec" line lets system tray icons show as expected, at least for Discord.

Re: Issues with software on KDE Plasma with xorg that don't appear with wayland

Reply #8
In my system with Artix OpenRC and KDE, Electron applications show their tray icons; however I can confirm the plasma integration being broken on Chromium.

Re: Issues with software on KDE Plasma with xorg that don't appear with wayland

Reply #9
It looks like a solution has been found here. Editing Plasma's desktop file to include "dbus-run-session" to the "Exec" line lets system tray icons show as expected, at least for Discord.
 
In my system with Artix OpenRC and KDE, Electron applications show their tray icons; however I can confirm the plasma integration being broken on Chromium.
 Upon installing libappindicator-gtk2 and libappindicator-gtk3 I can face the same issue and "fix" with the same fix proposed; however this "fix" shows incorrect app icons on my system (but menus seem to behave almost normally)

Re: Issues with software on KDE Plasma with xorg that don't appear with wayland

Reply #10
I did get the discord tray icon working by running DBUS_SESSION_BUS_ADDRESS=$(dbus-launch) in a terminal and then starting discord from the same terminal, but it displayed with a question mark. Notifications would also freeze the application. I have a feeling it has to do with DBUS_SESSION_BUS_ADDRESS, because it's not set at all. Let me also clarify that I'm using runit.
Someone on our TG group asked about dbus, and I've found that setting the DBUS_SESSION_BUS_ADDRESS variable from dbus-launch doesn't work reliably, at least for me.
What works is this:
Code: [Select]
% current_session=$(ls -t1 ~/.dbus/session-bus | head -1)
% source $current_session
% notify-send "Test"

Re: Issues with software on KDE Plasma with xorg that don't appear with wayland

Reply #11
With the latest update to libappindicator-gtk3 (12.10.0.r296-1), discord finally appears in my system tray again! However, the icon is still a question mark, and notifications still don't work.

Re: Issues with software on KDE Plasma with xorg that don't appear with wayland

Reply #12
With the latest update to libappindicator-gtk3 (12.10.0.r296-1), discord finally appears in my system tray again! However, the icon is still a question mark, and notifications still don't work.
That is because you surely miss some DBUS environment variables.
Can you please run this command?
Code: [Select]
% env | grep DBUS

Re: Issues with software on KDE Plasma with xorg that don't appear with wayland

Reply #13
Code: [Select]
KONSOLE_DBUS_SERVICE=:1.67
KONSOLE_DBUS_SESSION=/Sessions/1
KONSOLE_DBUS_WINDOW=/Windows/1