Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] Issues with software on KDE Plasma in xorg that don't appear in wayland (Read 1733 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: Issues with software on KDE Plasma with xorg that don't appear with wayland

Reply #15
Another application that recently started showing an incorrect icon was variety wallpaper changer, which required a restart before displaying the correct icon. I was able to get libayatana-appindicator installed, which fixed both variety and discord icons. However, discord still does not display notifications. I tried using the discord_arch_electron AUR package to see if using the system's electron would resolve this issue, but it did not.

Re: Issues with software on KDE Plasma with xorg that don't appear with wayland

Reply #16
Anyone got an update on this?
I'm facing the exact same problems with discord (and the browser integration). I've tried all the proposed solutions but sadly neither worked? So I was wondering if someone stumbled across another solution.

Edit: Unsure if dbus isssue as well because "export (dbus-launch)" fixes a warning from discord and also an error from the browser-integration. But sill the tray icon is bugged and the browser integration doesn't show media playing.

Edit2: Fixed! Turns out
It looks like a solution has been found here. Editing Plasma's desktop file to include "dbus-run-session" to the "Exec" line lets system tray icons show as expected, at least for Discord.
was the right solution... I just overlooked the relevant part.
So changing
"Exec=/usr/bin/startplasma-x11" to "Exec=dbus-run-session /usr/bin/startplasma-x11" in /usr/share/xsession/plasma.desktop
fixed it all Discord, Browser-Integration and Spotify.




Re: [SOLVED] Issues with software on KDE Plasma in xorg that don't appear in wayland

Reply #17
fixed now in plasma-workspace-5.21.3-1.1, dbus-run-session added to our plasma.desktop