Skip to main content
Topic: Xfce4 do not recognize the usb at PCMan FM File Manager (Read 2797 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Xfce4 do not recognize the usb at PCMan FM File Manager

Hi,

Xfce4 do not recognize the usb at PCMan FM File Manager, i found some information on google that recomeded some where  to install gamin and gvfs, pacman -Sy gvfs gamin but these packages are already installed in the system... What is missing here?. Just in case, with the other iso was not problem at all. dbus it is installed too. Thanks.

More information:

Code: [Select]
[[email protected] ~]$ lsblk -f
NAME   FSTYPE LABEL UUID                                 MOUNTPOINT
sda                                                     
├─sda1 ext4         a5ff07c1-db4a-45b2-9212-d242873e0ca3 /
├─sda2 swap         6934677e-dfee-43ca-80aa-83da08a25196 [SWAP]
├─sda3 ext4         8635c1cb-fc23-4090-824c-3d5b05d611cf
├─sda4                                                  
├─sda5 ext4         ec9ee698-19aa-4702-abd0-62d80142041b
└─sda6 ext4         3e0fe6f8-29b9-4592-b180-c0f4bf8cf9d1
sr0                                                     
[[email protected] ~]$

... and it is activated:



Mate
Desktop: xfce

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Re: Xfce4 do not recognize the usb at PCMan FM File Manager

Reply #1
Are you launching your X session with dbus? When I used openbox (now I just do 'dbus-launch sway'), I had to put the following in my .xinitrc for things like usb automounting.

Code: [Select]
exec dbus-launch openbox-session
I don't remember what the appropriate name is for xfce, but just replace openbox-session with that.

Re: Xfce4 do not recognize the usb at PCMan FM File Manager

Reply #2
i'm not sure if i understand what you says but from the terminal:

Code: [Select]
[kaos keos]# dbus-launch xfce4-session
dbus[2964]: Unable to set up transient service directory: XDG_RUNTIME_DIR "/run/user/1000" is owned by uid 1000, not our uid 0
xfce4-session: Another session manager is already running
Mate
Desktop: xfce

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Re: Xfce4 do not recognize the usb at PCMan FM File Manager

Reply #3
You need to edit your ~/.xinitrc file (create one if it doesn't exist) and put what's below in the file and then log out and log back in.

Code: [Select]
exec dbus-launch xfce4-session

Re: Xfce4 do not recognize the usb at PCMan FM File Manager

Reply #4
Well i see ... i never before has created any files on linux since i'm coming from Mint ... so i have been looking for some information about who to create a file, and this is what i got after many ...

Code: [Select]
[[email protected] Escritorio]$ cat > .xinitrc.txt

and nothing is created

Thanks.
Mate
Desktop: xfce

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Re: Xfce4 do not recognize the usb at PCMan FM File Manager

Reply #5
You can use the 'save' or 'save as' functionality of any text editor, and it will ask you for the filename and create it.

If you absolutely need to create an empty file (not so common), issue 'touch filename'. To create a directory (folder), issue 'mkdir dirname'.

The 'cat' command reads from a file and outputs its contents. The '>' operator would redirect that to another file. The command you posted reads from absolutely no file at all, and tries to save that nothing to another file, that's why it doesn't succeed.

Re: Xfce4 do not recognize the usb at PCMan FM File Manager

Reply #6
Also there's no need for the ".txt" extension. The file is just called ".xinitrc"

Re: Xfce4 do not recognize the usb at PCMan FM File Manager

Reply #7
i'm not sure if i understand what you says but from the terminal:

Code: [Select]
[kaos keos]# dbus-launch xfce4-session
dbus[2964]: Unable to set up transient service directory: XDG_RUNTIME_DIR "/run/user/1000" is owned by uid 1000, not our uid 0
xfce4-session: Another session manager is already running

You shouldn't be trying to start the session or dbus as root, which produces the error you posted above.

Re: Xfce4 do not recognize the usb at PCMan FM File Manager

Reply #8
Try putting this in  the start up menu in user settings     dbus-launch pcmanfm --desktop -d it works fine here with pcmanfm.

Re: Xfce4 do not recognize the usb at PCMan FM File Manager

Reply #9
Code: [Select]
[[email protected] ~]$ dbus-launch xfce4-session
xfce4-session: Another session manager is already running
[[email protected] ~]$

i don't know what is this since nothing at the moment is running ...

Also i create a file with  kwrite and i add the order ... i can't open the usb, nothing happen ... and i don't see the file with the command whereis

 
Code: [Select]
[[email protected] ~]$ whereis .xinitrc
: /usr/bin/. /usr/lib/. /etc/. /usr/local/bin/. /usr/local/sbin/. /usr/local/etc/. /usr/local/lib/. /usr/local/games/. /usr/include/. /usr/local/. /usr/share/. /usr/bin/site_perl/. /usr/bin/vendor_perl/. /usr/bin/core_perl/. /usr/share/man/pl.ISO8859-2/. /usr/share/man/sr/. /usr/share/man/it/. /usr/share/man/ru.UTF-8/. /usr/share/man/man2/. /usr/share/man/uk/. /usr/share/man/fr.UTF-8/. /usr/share/man/zh_TW/. /usr/share/man/pl/. /usr/share/man/pt_BR/. /usr/share/man/es/. /usr/share/man/fr/. /usr/share/man/pl.UTF-8/. /usr/share/man/man3/. /usr/share/man/tr/. /usr/share/man/sv/. /usr/share/man/el/. /usr/share/man/man1/. /usr/share/man/man4/. /usr/share/man/pt/. /usr/share/man/cs/. /usr/share/man/it.UTF-8/. /usr/share/man/id/. /usr/share/man/ar/. /usr/share/man/ug/. /usr/share/man/man5/. /usr/share/man/jp/. /usr/share/man/hu/. /usr/share/man/man0/. /usr/share/man/fr.ISO8859-1/. /usr/share/man/de/. /usr/share/man/ko/. /usr/share/man/ja/. /usr/share/man/sl/. /usr/share/man/ca/. /usr/share/man/ru.KOI8-R/. /usr/share/man/gl/. /usr/share/man/da/. /usr/share/man/zh_CN/. /usr/share/man/lt/. /usr/share/man/man8/. /usr/share/man/nl/. /usr/share/man/man6/. /usr/share/man/ru/. /usr/share/man/it.ISO8859-1/. /usr/share/man/man7/. /usr/share/info/.
[[email protected] ~]$
Mate
Desktop: xfce

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Re: Xfce4 do not recognize the usb at PCMan FM File Manager

Reply #10
If you still have consolekit running, purge it from the system. elgind and ck don't play nice together.

Re: Xfce4 do not recognize the usb at PCMan FM File Manager

Reply #11
consolekit is not installed
Mate
Desktop: xfce

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Re: Xfce4 do not recognize the usb at PCMan FM File Manager

Reply #12
from openbox when i insert the usb i got this message: ERROR /run/media/keos/USB%20STICK: do not exist the file ....
Mate
Desktop: xfce

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Re: Xfce4 do not recognize the usb at PCMan FM File Manager

Reply #13
Code: [Select]
[[email protected] ~]$ dbus-launch xfce4-session
xfce4-session: Another session manager is already running
[[email protected] ~]$

i don't know what is this since nothing at the moment is running ...

Also i create a file with  kwrite and i add the order ... i can't open the usb, nothing happen ... and i don't see the file with the command whereis

 
Code: [Select]
[[email protected] ~]$ whereis .xinitrc
: /usr/bin/. /usr/lib/. /etc/. /usr/local/bin/. /usr/local/sbin/. /usr/local/etc/. /usr/local/lib/. /usr/local/games/. /usr/include/. /usr/local/. /usr/share/. /usr/bin/site_perl/. /usr/bin/vendor_perl/. /usr/bin/core_perl/. /usr/share/man/pl.ISO8859-2/. /usr/share/man/sr/. /usr/share/man/it/. /usr/share/man/ru.UTF-8/. /usr/share/man/man2/. /usr/share/man/uk/. /usr/share/man/fr.UTF-8/. /usr/share/man/zh_TW/. /usr/share/man/pl/. /usr/share/man/pt_BR/. /usr/share/man/es/. /usr/share/man/fr/. /usr/share/man/pl.UTF-8/. /usr/share/man/man3/. /usr/share/man/tr/. /usr/share/man/sv/. /usr/share/man/el/. /usr/share/man/man1/. /usr/share/man/man4/. /usr/share/man/pt/. /usr/share/man/cs/. /usr/share/man/it.UTF-8/. /usr/share/man/id/. /usr/share/man/ar/. /usr/share/man/ug/. /usr/share/man/man5/. /usr/share/man/jp/. /usr/share/man/hu/. /usr/share/man/man0/. /usr/share/man/fr.ISO8859-1/. /usr/share/man/de/. /usr/share/man/ko/. /usr/share/man/ja/. /usr/share/man/sl/. /usr/share/man/ca/. /usr/share/man/ru.KOI8-R/. /usr/share/man/gl/. /usr/share/man/da/. /usr/share/man/zh_CN/. /usr/share/man/lt/. /usr/share/man/man8/. /usr/share/man/nl/. /usr/share/man/man6/. /usr/share/man/ru/. /usr/share/man/it.ISO8859-1/. /usr/share/man/man7/. /usr/share/info/.
[[email protected] ~]$
".xinitrc" should be in your home directory but because it is dot file it may be hidden.

Re: Xfce4 do not recognize the usb at PCMan FM File Manager

Reply #14
The .xinitrc file is located in your user's home directory. Its contents are used by the startx command.

There are linux distributions that come configured out of the box for desktop usage, such as Ubuntu, Fedora, Manjaro and a few others. Artix is not beginner friendly in this regard, I'm not saying you shouldn't use it, but if you want your system to be a friendly, problem free desktop environment that simply works, there are other options out there that will not cause trouble.

The whereis command locates binaries in the $PATH, not files in the local directory.