Skip to main content
Topic: Packagers wanted! (Read 6140 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

Packagers wanted!

We urgently need more people able to contribute to packaging.

You don't have to be an expert in the occult arts for that; an elementary grasp of Linux in general and how PKGBUILD works should be enough for basic contributions. Help and training will be provided, free of charge!

You can apply here or in PM.

Re: Packagers wanted!

Reply #1
Count me in


Re: Packagers wanted!

Reply #3
Guess I'll never know if I don't try, PM me and we can look for a date for me to frustrate you  :P

Re: Packagers wanted!

Reply #4
My time is pretty limited, but I might be able to help some.  I used to maintain several of the orphaned OCaml libraries in Arch so I have some experience with PKGBUILD.  What is involved?

Re: Packagers wanted!

Reply #5
I may be able to help, let me know.

Re: Packagers wanted!

Reply #6
My time is pretty limited, but I might be able to help some.  I used to maintain several of the orphaned OCaml libraries in Arch so I have some experience with PKGBUILD.  What is involved?
I may be able to help, let me know.

Replying in PM.

Re: Packagers wanted!

Reply #7
Yup, I'd like to help with that as well!

Re: Packagers wanted!

Reply #8
Hey man I just made my first 3 PKGBUILD's, I made them out of git repos instead of them being like actual packages with version numbers/etc, all I really need to learn is how to give it a version number & how to make it automate its own updates...

like... when there's a new package available to be packaged, how do we know? Do the packages just update themselves or do we need to alter the PKGBUILD to make it update in the package manager?  I can start with gaming emulators, I have so far done Dolphin-emu, Citra-emu & Medusa-emu, once I am more experienced I'll be able to do other packages. Maybe in a few months I'll have enough experience to do more packages but I would prefer to start with stuff that requires cmake, qmake or ./configure

Inbox me if you don't mind & just teach me a few of the things I have mentioned here that I don't understand & I'll be good-to-go for the simple packages, and you guys can look over the first ones I make to make sure I am doing everything right & give me tips about what I am doing wrong. This is the first one I made, I made a similar one for citra-emu & medusa-emu.

Code: [Select]

pkgname=dolphin-emu-fresh
pkgver=0
pkgrel=1
pkgdesc='A GameCube / Wii / Triforce emulator'
arch=('x86_64')
url='http://www.dolphin-emu.org/'
license=('GPL')
depends=('alsa-lib' 'bluez-libs' 'cairo' 'enet' 'gcc-libs' 'gdk-pixbuf2'
         'glib2' 'glibc' 'gtk2' 'hidapi' 'libevdev' 'libgl' 'libpng' 'libpulse'
         'libsm' 'libx11' 'libxi' 'libxrandr' 'libxxf86vm' 'lzo' 'mbedtls'
         'miniupnpc' 'pango' 'sfml' 'zlib' 'pulseaudio' 'ffmpeg' 'pugixml'
'bluez' 'bluez-utils-compat' 'bluez-firmware' 'bluez-plugins'
'bluez-libs' 'bluez-qt' 'bluez-tools' 'bluez-openrc' 'curl' 'xorg-xinput'
         'libeudev' 'libusb' 'libgusb' 'libusb-compat' 'lib32-libusb' 'libtiger'
'pangomm' 'pangox-compat' 'libglvnd' 'sndio' 'alsa-plugins' 'alsa-firmware'
'alsa-utils' 'alsa-lib' 'pulseaudio-alsa' 'alsa-oss')

makedepends=('cmake' 'git' 'qt5-base' 'pango' 'fakeroot')
source=('dolphin-emu::git+https://github.com/dolphin-emu/dolphin.git')
sha256sums=('SKIP')

build() {
git clone https://github.com/dolphin-emu/dolphin.git
mkdir -p dolphin/build
cd dolphin/build

cmake -DOpenGL_GL_PREFERENCE=GLVND -DUSE_X11=1 -DUSE_EGL=1 -DCMAKE_INSTALL_PREFIX=/usr -DENABLE_QT2=TRUE -DCMAKE_BUILD_TYPE=Release ..
make -j48
}

package() {
cd dolphin/build

make DESTDIR="${pkgdir}" install
install -Dm 644 ../Data/51-usb-device.rules -t "${pkgdir}"/usr/lib/udev/rules.d/
}


# make install
# install -Dm 644 ../Data/51-usb-device.rules -t "${pkgdir}"/usr/lib/udev/rules.d/

# vim: ts=2 sw=2 et:


Re: Packagers wanted!

Reply #9
@kenny_w Be aware that git packages belong to AUR only and should have "-git" suffix in the package name.
these git packages are mostly used to test new features...
"-git" pgkbuilds are updated only when there is something wrong with current pkgbuild or when there was change in buildsystem...
these pkgbuilds can stay unchanged for years and when building always offer newest version.
git pkgbuilds usually have "version" function, so when you build them the version is set to current one.

Normal PKGBUILDS used in our repositories are downloading specific version of desired program,
PKGBUILD is updated when the new release is made or when there is some error with pkgbuild.

PKGBUILD which you posted is mixture of these, it is good for personal use but nightmare for others.
- downloads source from git (build is not stable, you cant offer stable package)
- Package name should reflect that the source is from git with "-git" suffix
- Package version should specify program version (in case of "-git" package provide "version" function)
- Make things easy to read (dont mix tabs and spaces,  indent body of functions)
- Long lines are hard to read, if you can cut long line to multiple short lines

These are my thoughts regarding this subject, i might also be totally wrong :D.
Happy falling

Re: Packagers wanted!

Reply #10
@nous  I may be able to help some let me know what you need

Re: Packagers wanted!

Reply #11
Do you need extra package maintainers or not? I'd be happy to help.

 

Re: Packagers wanted!

Reply #13
Not much free time, nor an expert but would like helping in this regard.